KUL - Kuala Lumpur, Malaysia
Incident Report for StrongVPN
Resolved
No further reports of this issue have been received.
Posted Mar 20, 2024 - 19:01 UTC
Update
There are numerous fiber cuts causing disruptions with KUL. Our upstream provider is currently making adjustments to address this issue.

Once the fiber cut issues are resolved, the network problem should be resolved as well. Currently, we do not have an estimated time of when this issue will be fixed. We apologize for the service disruption and any inconvenience caused.
Posted Mar 17, 2024 - 05:01 UTC
Update
Our upstream provider is currently investigating potential service disrupting issues in this location. We will continue to monitor this location.
Posted Mar 15, 2024 - 03:28 UTC
Investigating
We are currently investigating a potential service impacting situation in this location.
Posted Mar 14, 2024 - 16:46 UTC
This incident affected: Server Status.