Event start updated to 2025-09-09 16:00:00 Event end updated to 2025-09-09 19:00:00
Posted Aug 22, 2025 - 16:25 UTC
Scheduled
We will be performing maintenance on our network infrastructure in our main datacenter. While this maintenance work is being performed, you may experience one or more brief interruptions in service. This notification is a courtesy to keep you informed of our activities in case you experience any unexpected issues.
Posted Aug 14, 2025 - 16:48 UTC
This scheduled maintenance affects: Server Status.