TOR - Toronto, Canada - UPDATE
Incident Report for StrongVPN
Resolved
YYZ Disruption - Hardware issue that affected tor-b01 - tor-b07
All of the servers are back online.
Posted Mar 17, 2024 - 01:49 UTC
Update
YYZ Disruption - Hardware issue that affected tor-b01 - tor-b07
Posted Mar 17, 2024 - 01:48 UTC
Identified
YYZ Disruption - Hardware issue that affected tor-b01 - tor-b07
Posted Mar 17, 2024 - 01:46 UTC
This incident affected: Server Status.