HKG - Hong Kong Partial Outage

Incident Report for StrongVPN

Resolved

This incident has been resolved.
Posted Jul 28, 2025 - 17:17 UTC

Investigating

We are experiencing a partial outage with the Hong Kong servers.The upstream provider is aware of the issue and is working to resolve the problem.issue and is working to resolve the problem.
Posted Jul 26, 2025 - 04:40 UTC
This incident affected: Server Status.