Hong Kong

Incident Report for StrongVPN

Resolved

We have received no further reports of this issue.
Posted Mar 24, 2026 - 02:05 UTC

Investigating

There is currently a maintenance starting in this location.  We apologize for the inconvenience.  Servers will not be available.
Posted Mar 23, 2026 - 17:14 UTC
This incident affected: Server Status.