Lima Peru Maintenance Updates

Scheduled for Feb 14, 05:30 - 08:30 UTC

Update

Event start updated to 2026-02-14 05:30:00
Event end updated to 2026-02-14 08:30:00
Posted Feb 09, 2026 - 08:39 UTC

Scheduled

Lima Peru Maintenance Updates
Posted Feb 07, 2026 - 01:41 UTC
This scheduled maintenance affects: Server Status.