On going maintenance for Paris France, servers will not be available at this time.

Incident Report for StrongVPN

Resolved

This incident has been resolved.
Posted Mar 26, 2026 - 14:55 UTC

Investigating

Maintenance is currently in progress in Paris, France. Servers are temporarily unavailable at this time.
Posted Mar 26, 2026 - 03:14 UTC
This incident affected: Server Status.